Mail Send requests delays
Incident Report for Amply
Resolved
Our engineers have monitored the fix and confirmed any delays have been resolved. All systems are operating as expected at this time.
Posted Oct 25, 2023 - 17:49 UTC
Monitoring
A fix was implemented at approximately 9:36 AM PDT. Our engineers are currently monitoring to ensure no more delay occurrences are detected.
Posted Oct 25, 2023 - 16:51 UTC
Update
We are continuing to investigate this issue.
Posted Oct 25, 2023 - 16:48 UTC
Investigating
Starting around 9:11 AM PDT on 25 October 2023, our engineers have began investigating an issue with mail send requests delays for SMTP or API. Customers may experience delay responses for mail send requests. We will provide another update within 1 hour or as soon as more information becomes available.
Posted Oct 25, 2023 - 16:26 UTC
This incident affected: sendamply.com, API Requests, and SMTP Relay.